HDU 5536--Chip Factory(暴力)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Enterprise_/article/details/82932853

Chip Factory
Time Limit: 18000/9000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 5394 Accepted Submission(s): 2422

Problem Description
John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk

which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Input
The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,…,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100

Output
For each test case, please output an integer indicating the checksum number in a line.

Sample Input
2
3
1 2 3
3
100 200 300

Sample Output
6
400

扫描二维码关注公众号,回复: 4021748 查看本文章

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

时间充裕,暴力一发0.0

#include <iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int a[1005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m=-999;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                for(int k=j+1;k<n;k++){
                    m=max(m,(a[i]+a[j])^a[k]);
                    m=max(m,(a[j]+a[k])^a[i]);
                    m=max(m,(a[i]+a[k])^a[j]);
                }
            }
        }
        printf("%d\n",m);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Enterprise_/article/details/82932853
今日推荐