【01字典树模板题】HDU - 5536 B - Chip Factory

B - Chip Factory HDU - 5536 

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces nn chips today, the ii-th chip produced this day has a serial number sisi. 

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below: 

max (si+sj)⊕sk


which i,j,ki,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR. 

Can you help John calculate the checksum number of today?

Input

The first line of input contains an integer T indicating the total number of test cases. 

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has nn integers s1,s2,..,sn, separated with single space, indicating serial number of each chip. 

1≤T≤1000
3≤n≤1000
0≤si≤10^9
There are at most 10 testcases with n>100

Output

For each test case, please output an integer indicating the checksum number in a line.

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400

给你n个数,区三个不同的数,a[i],a[j],a[k],问你(a[i]+a[j])^a[k]最大值是多少?

先把所有的数建成01字典树,然后再枚举a[i]+a[j]删除,在进去查找异或最大值,记得再加回来

#include<bits/stdc++.h>
#define ll long long
using namespace std;
int a[2005],ch[35*1005][2],val[35*1005];
int tol;

void insert(ll x,ll p)
{
    int u=0;
    for(int i=31;i>=0;i--)
    {
        int v=(x>>i)&1;
        if(!ch[u][v])
            ch[u][v]=tol++;
        u=ch[u][v];
        val[u]+=p;
    }
}

ll query(ll x)
{
    int u=0;
    ll ans=0;
    for(int i=31;i>=0;i--)
    {
        int v=(x>>i)&1;
        if(val[ch[u][v^1]])
            u=ch[u][v^1],ans|=(1<<i);
        else
            u=ch[u][v];
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        tol=1;
        int n;
        scanf("%d",&n);
        for(int i=0;i<=n*32;i++) ch[i][0]=ch[i][1]=val[i]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            insert(a[i],1);
        }
        ll maxx=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                insert(a[i],-1);
                insert(a[j],-1);
                maxx=max(maxx,query(a[i]+a[j]));
                insert(a[j],1);
                insert(a[i],1);
            }
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/82837765
今日推荐