G - Seek the Name, Seek the Fame

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

这个题的意思就是在文本串中找一些字符串,它既是文本串的前缀也是文本的后缀,然后输出他们的长度

这题是考察了KMP的一些性质,例:ababcabab ababcabab串中,ababcabab既是前缀也是后缀,如果对前面ababcabab进行查询,那么也是对后面的ababcabab也在进行查询操作。所以在前面求前缀后缀相同时,也就保证了在总文本串中前缀后缀相同

#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
const int maxn=4e5+10;
char b[maxn];
int ne[maxn];
void get(int len)
{
	int i,j=-1;
	ne[0]=-1;
	for(int i=0;i<len;)
	{
		if(j==-1||b[i]==b[j]) ne[++i]=++j;
		else j=ne[j];
	}
}
int main()
{
	while(~scanf("%s",b))
	{
		int len=strlen(b);
		get(len);
		stack<int> que;
		int i=ne[len];
		while(i>0)
		{
			que.push(i);
			i=ne[i];
		}
		while(!que.empty())
		{
			int x=que.top();
			que.pop();
			printf("%d ",x);
		}
		printf("%d\n",len);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41286356/article/details/85029142