Seek the Name, Seek the Fame 【hash/KMP】

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

思路字符串hash或者KMP

hashcode:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=4e5+10;
char s[maxn];
typedef unsigned long long ull;
ull a[maxn],has[maxn];
const int p=223;
void hash(){
	has[0]=s[0];
	int l=strlen(s);
	for(int i=1;i<l;i++) has[i]=has[i-1]*p+s[i];
	a[1]=p;
	for(int i=2;i<maxn;i++)	a[i]=a[i-1]*p;
}
ull cut(int i,int x){
	if(i) return has[i+x-1]-has[i-1]*a[x];
	return has[x-1];
}
int main(){
	while(cin>>s){
		hash();
		int l=strlen(s);
		for(int i=1;i<=l;i++){//长度 
			if(cut(0,i)==cut(l-i,i)) 
			cout<<i<<' ';
		}
		cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41333844/article/details/81836827