POJ2572(Seek the Name, Seek the Fame)

Seek the Name, Seek the Fame
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14398   Accepted: 7188

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5
题意:找到字符串后缀和前缀相同的所有长度,并升序输出。

思路:kmp,对kmp进一步理解即可写出。

kmp算法中,next [i] = k 表示第i - k + 1个元素到第 i 个元素与字符串的前k位相同;那么要统计后缀与前缀相同的个数,只需在next数组中以next [ len ](len为字符串长度)为起点向前查找即可。注意到第 i 位的字符必与 k 位的字符相同,且其前面的字符在对应位置的也一一相同,那么令i = k的方式向前查找,每次查找的 k 值即为一个后缀与前缀相同的长度。且查找到的k值严格递减,那么存储下来逆序输出即可。

#include<cstdio>
#include<cstring>
char a[400005];
int nxt[400005],ans[400005],len;
void getnxt(){
	int i = - 1, j = 0;
	nxt[0]=-1;
	while(j<=len){
		if(i==-1||a[i]==a[j]){
			nxt[++j]=++i;
		}
		else i=nxt[i];
	}
}
int main(){
	while(~scanf("%s",a)){
		len=strlen(a);
		memset(nxt,0,sizeof(nxt));
		getnxt();
		int k=0;
		for(int i = nxt[len];i>0;i=nxt[i]){
			ans[k++]=i;
		}
		for(int i =k-1; i >=0; i--){
			printf("%d ",ans[i]);
		}
		printf("%d\n",len);
	}
	return 0;
}





猜你喜欢

转载自blog.csdn.net/Mad_boys/article/details/47954109