Seek the Name, Seek the Fame(KMP next数组)

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

大致题意:

输入一个字符串,输出字符串中既是它前缀又是它后缀的子串的长度,要求长度从小到大输出。

这道题需要用到KMP的next前缀数组的特性来解。

#include<cstdio>
#include<cstring>
using namespace std;
const int N=4e5+5;
char s[N];
int next[N];
int q[N],cnt=0;
void getnext(char s[],int len){
	int j=-1;
	next[0]=-1;
	for(int i=1;i<len;i++){
		while(j!=-1&&s[i]!=s[j+1]) j=next[j];
		if(s[i]==s[j+1]) j++;
		next[i]=j;
	}
}
int main(){
	while(~scanf("%s",s)){
		int len=strlen(s);
		getnext(s,len);
		int a=next[len-1];
		cnt=0;
		while(a!=-1){
			q[++cnt]=a+1;
			a=next[a];
		}
		for(int i=cnt;i>=1;i--){
			printf("%d ",q[i]);
		}
		printf("%d\n",len);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42936517/article/details/87903634