POJ—2752 Seek the Name, Seek the Fame

版权声明:请联系[email protected] https://blog.csdn.net/wanglin007/article/details/84401698

Time Limit: 2000MSMemory Limit: 65536KTotal Submissions: 24952Accepted: 12999DescriptionThe little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

InputThe input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

OutputFor each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.Sample Inputababcababababcabab
aaaaa
Sample Output2 4 9 18
1 2 3 4 5
SourcePOJ Monthly–2006.01.22,Zeyuan Zhu

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
int next[400005];
void Next(char T[])
{
 int l=strlen(T),i=0,k=-1;
 next[0]=-1;
 while(i<l)
 {
  if(T[i]==T[k]||k==-1)next[++i]=++k;
  else k=next[k];
 }
}
int main()
{
 char T[400005];
 while(scanf("%s",&T)!=EOF)
 {
  stack<int>s;
  int i=strlen(T);
  Next(T);
  while(i>0)
  {
   s.push(i);
   i=next[i];
  }
  while(!s.empty())
  {
   printf("%d",s.top());
   s.pop();
   if(!s.empty())printf(" ");
   else printf("\n");
  }
 }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/wanglin007/article/details/84401698