PAT甲级1041,1042解题报告

1041 Be Unique (20 分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题目大意:输出第一个,在序列中没有重复出现的数。

解题思路:以前有一道比较难的,输出一个在序列中出现次数为奇数的,用异或就可以解决了,这里的比较简单,简单用一下map映射到这个数出现的次数就可以了。因为时间限制只能进行一次循环。

代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
map<int, int> a;
int num[100005];
int main()
{
	int n;
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> num[i];
		a[num[i]] += 1;
	}
	bool flag = false;
	for (int i = 0; i < n; i++) {
		if (a[num[i]] == 1) {
			flag = true;
			cout << num[i] << endl;
			break;
		}
	}
	if (!flag)cout << "None" << endl;
	return 0;
}

1042 Shuffling Machine (20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目大意:模拟一下洗牌过程,英文是看不太懂的一开始,后来看到这54张牌大概就懂了。

解题思路:暴力过,每次洗牌的过程都用个临时的vector记录还没开始洗的上一次结果,然后直接把上一次结果的数组根据你输入的洗牌顺序修改,这样即使是20次,规模也就是在1000左右,400ms的时间限制肯定是绰绰有余的。

代码如下:

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
vector<int> order;
vector<string> s;
void init() {
	for (int i = 1; i <= 13; i++) {
		s.push_back("S" + to_string(i));
	}
	for (int i = 1; i <= 13; i++) {
		s.push_back("H" + to_string(i));
	}
	for (int i = 1; i <= 13; i++) {
		s.push_back("C" + to_string(i));
	}
	for (int i = 1; i <= 13; i++) {
		s.push_back("D" + to_string(i));
	}
	s.push_back("J1");
	s.push_back("J2");
}
int main()
{
	init();
	int K;
	cin >> K;
	for (int i = 0; i < 54; i++) {
		int c;
		cin >> c;
		order.push_back(c);
	}
	for (int i = 0; i < K; i++) {
		vector<string> tmp = s;
		for(int j=0;j<54;j++)
		s[order[j]-1] = tmp[j];
	}
	for (int i = 0; i < 54; i++) {
		if (i != 53)
			cout << s[i] << " ";
		else
			cout << s[i] << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/TateBrwonJava/article/details/83055294
今日推荐