POJ-2142-The Balance (扩展欧几里得算法)

版权声明:欢迎评论与转载,转载时请注明出处! https://blog.csdn.net/wjl_zyl_1314/article/details/84877105

原题链接:
Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights.
You are asked to help her by calculating how many weights are required.

在这里插入图片描述
Input
The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider “no solution” cases.
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.
Output
The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions.
You can measure dmg using x many amg weights and y many bmg weights.
The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition.
The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.
Sample Input
700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0
Sample Output
1 3
1 1
1 0
0 3
1 1
49 74
3333 1
题意:
有重量为a和b的砝码(无限多个),用x个a砝码,y个b砝码来称量重量为d的砝码,要求x+y最小。
题解:
有两种测量方式
1.(x个a和d)的重量y个b的重量 exgcd(b,a,x1,y1)
2.(y个b和d)的重量
x个a的重量 exgcd(a,b,x1,y1)
也就可以列出两种类型的方程,而且题目说明一定有解。所以利用扩展欧几里得算法可以解出两组解,比较x+y的大小即可。
附上AC代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int exgcd(int a,int b,int &x,int& y)//扩展欧几里得算法
{
    if(b==0)
    {
        x=1,y=0;
        return a;
    }
    int q=exgcd(b,a%b,y,x);
    y-=a/b*x;
    return q;
}
int main()
{
    int a,b,d,x1,y1,x2,y2;
    while(scanf("%d%d%d",&a,&b,&d)!=EOF,a&&b&&d)
    {
        int g1=exgcd(a,b,x1,y1);
        int g2=exgcd(b,a,x2,y2);
        x1*=(d/g1);
        y1*=(d/g1);
        x2*=(d/g2);
        y2*=(d/g2);
        int t1=b/g1;
        x1=(x1%t1+t1)%t1;//规范x1:使得x1是满足条件的最小的一组解
        y1=abs(a*x1-d)/b;//利用方程解出y1
        int t2=a/g2;
        x2=(x2%t2+t2)%t2;//同上,只不过这里x2是b的个数
        y2=abs(b*x2-d)/a;
        if((x1+y1)<(x2+y2))
            printf("%d %d\n",x1,y1);
        else
            printf("%d %d\n",y2,x2);//注意输出顺序
    }
    return 0;
}

欢迎评论!

猜你喜欢

转载自blog.csdn.net/wjl_zyl_1314/article/details/84877105