POJ2142The Balance 扩展欧几里得求解最小砝码数量

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 8764   Accepted: 3806

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 

  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.


No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

Source

Japan 2004

题目大意:

现在有两种类型的砝码,每种砝码的质量为a,b要称重的物品质量为n要求:最小的砝码(x或者y最小优先,其次x+y最小优先)

思路:

扩展欧几里得:a*n*x+b*n*y=n;为什么有乘以n呢?

题目上说给出的每个a,b都有相应的解,所以,gcd(a,b)=1;

所以可以将式子变为,a*x+b*y=1;

由于题意为 ax+n=by 或 ax= by+n;

则 先求x为最小正整数,y为负数可取反;求y最小同理;

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int gcd(int a, int b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}

void exgcd(int a,int b,int &x,int &y)
{
    if(b==0)
    {
        x=1;y=0;
        return ;
    }
    exgcd(b,a%b,y,x);
    y-=a/b*x;
    return ;
}

int main()
{
    int a,b,n;
    while(scanf("%d%d%d",&a,&b,&n)!=EOF)
    {

        if(!a&&!b&&!n)
            break;
        int mod=gcd(a,b);
        a=a/mod;
        b=b/mod;
        n=n/mod;//将式子变为a*x+b*y=1的形式。
        int x,y,nx,ny,mx,my;
        exgcd(a,b,x,y);
        nx=x*n;
        nx=(nx%b+b)%b;//最小的x,也就是nx,要通过它求出ny,ny取正值
        ny=(n-a*nx)/b;
        if(ny<0)
            ny=-ny;
         my=y*n;
        my=(my%a+a)%a;
        mx=(n-b*my)/a;
        if(mx<0)mx=-mx;
        if(nx+ny>mx+my)
        {
            nx=mx;ny=my;
        }
        cout<<nx<<" "<<ny<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/81566603