数论题集1-4(扩展欧几里得)-- POJ - 2142 The Balance

The Balance

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 8601   Accepted: 3735

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 

  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.


No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

题意:

给你三组数据 , 分别表示  a 重量的砝码 和 b 重量的砝码 , 用 a 和 b 来称取 c 的重量。

即 a * x  = b * y + c ;  或  b * tx  = a * ty + c;

要判断(x+y) 和 (tx + ty)的大小 , 谁小就输出谁

代码:

#include <stdio.h>
#include <iostream> 
#define ll long long
using namespace std;
ll ExEuclid(ll a , ll b , ll &x , ll &y)
{
	if(b == 0)
	{
		x = 1;y = 0;
		return a;
	}
	ll tx , ty;
	ll d = ExEuclid(b , a%b , tx , ty);
	x = ty;
	y = tx - (a/b)*ty;
	return d ;
}
int main()
{
	ll A , B , K ;
	ll a , b , c , x , y , tx , ty;
	while(~scanf("%lld %lld %lld" , &a , &b , &K) &&(a+b+K))
	{
		A = b ; B = a;
		ll d = ExEuclid(a , b , x , y);
		x = x * K / d;
		ll t = b / d;
		ll xx = (x % t + t) % t;
		y = (K - a * xx)/b;
		if(y < 0) y = -y;
	//	printf("xx = %lld  y = %lld\n" , xx ,y);
		
		
		ll r = ExEuclid(A, B , tx , ty);
		tx = tx * K / r;
		ll t1 = B / r;
		ll xx1 = (tx % t1 + t1) % t1;
		ty = (K - A * xx1)/B;
		if(ty < 0) ty = -ty;
	//	printf("xx1 = %lld  ty = %lld\n" , xx1 , ty);
		if(xx + y > xx1 + ty)
		{
			printf("%lld %lld\n"  , ty , xx1);
		 } 
		 else
		 {
		 	printf("%lld %lld\n" , xx , y);
		 }
	 } 
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41593380/article/details/81289738