UVA 10305- Ordering Tasks(经典拓扑排序)

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3

注意,输出的数据可能和所给的事例不一样,只要符合其中一种就好。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 101;
int n, m, t;
int gragh[maxn][maxn], res[maxn], c[maxn];

bool dfs(int u) {
	c[u] = -1;
	for (int v = 0; v < n; v++)
		if (gragh[u][v])
			if (c[v] < 0)
				return false;
			else if (!c[v] && !dfs(v))
				return false;
	c[u] = 1;
	res[--t] = u;
	return true;
}

bool toposort() {
	t = n;
	memset(c, 0, sizeof(c));
	for (int u = 0; u < n; u++)
		if (!c[u])
			if (!dfs(u))
				return false;
	return true;
}

int main() {
	while (scanf("%d%d", &n, &m) && (n || m)) {
		memset(gragh, 0, sizeof(gragh));
		int a, b;
		for (int i = 0; i < m; i++) {
			scanf("%d%d", &a, &b);
			gragh[a-1][b-1] = 1;
		}
		toposort();
		for (int i = 0; i < n; i++)
			printf("%d ", res[i] + 1);
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Endeavor_G/article/details/84801642