UVA-10305 Ordering Tasks

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1<=n<=100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j,representing the fact that task i must be executed before task j. An instance with n=m=0 will finish the input.
Output For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
SSample Output
1 4 2 5 3

题意:有n个数,m种已知排序,要求给出n个数可能的排序方式。把每个变量看成一个点,小于关系看成有向边,这样就把问题转换成了一个图的所有结点排序,即拓扑排序。

#include<cstdio>
#include<cstring>
#define N 105
using namespace std;

int n,m,t=0,a[N][N],vis[N],stack[N];

void push(int x){
    stack[t++]=x;
}

void dfs(int x){
    vis[x]=-1;
    for(int i=1;i<=n;i++){
        if(a[x][i]&&(!vis[i])){
            dfs(i);
        }
    }
    push(x);vis[x]=1;
}

int main(){
    int u,v;
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0)
        break;
        memset(vis,0,sizeof(vis));
        memset(a,0,sizeof(a));
        while(m--){
            scanf("%d%d",&u,&v);
            a[u][v]=1;
        }
        for(int i=1;i<=n;i++){
            if(!vis[i])
            dfs(i);
        }
        
        while(t){
            printf("%d",stack[--t]);
            printf("%c",t>0?' ':'\n');
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/yimo_180227/article/details/80466931