Generating Fast(全排列函数)

Generating permutation has always been an important problem in computer science. In this problem
you will have to generate the permutation of a given string in ascending order. Remember that your
algorithm must be efficient.
Input
The first line of the input contains an integer n, which indicates how many strings to follow. The next
n lines contain n strings. Strings will only contain alpha numerals and never contain any space. The
maximum length of the string is 10.
Output
For each input string print all the permutations possible in ascending order. Not that the strings should
be treated, as case sensitive strings and no permutation should be repeated. A blank line should follow
each output set.
Sample Input
3
ab
abc
bca
Sample Output
ab
ba
abc
acb
bac
bca
cab
cba
abc
acb
bac
bca
cab
cba

题目应该是很简单了,就是几个字母的组合,要是重复的就只打出一个来就行了
全排列可以用深搜实现,也可以用c++函数,在这里我用的函数,代码短。
代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

char s[11];

int main()
{
	int t;
	scanf("%d",&t);
	getchar(); 
	while(t--)
	{
		gets(s);
		int len=strlen(s);
		sort(s,s+len);//首先一开始的顺序应该是有序的。
		do{    
			puts(s);
  		} while ( next_permutation(s,s+len) );//字典序有小到大。
  		printf("\n");
	}
}

努力加油a啊,(o)/~

猜你喜欢

转载自blog.csdn.net/starlet_kiss/article/details/84579824