杭电ACM-1050 Moving Tables

                                            Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43080    Accepted Submission(s): 14081

 

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

 

Sample Input

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

Sample Output

10

20

30

题目大意是给N组数,每组数代表的是从a房间搬桌子到b房间,求搬完N组需要的最短时间,

注意,不管从哪里搬到哪里都只会花费10分钟。

(开始没看清题,先看的样例1,还以为是1分钟一个房间,自我迷失了半天)

解题思路:

有两种情况:

第一种是所有的路线不重叠,时间就是10分钟。

第二种情况是路线交叉,那么就需要两次或者更多次来完成搬桌子,需要的时间就是  次数 乘以  10分钟。

具体AC代码如下:

 

//#include<bits/stdc++.h>
#include<iostream>
#include<cstring>
//经过本房间次数最多的乘以10分钟就是用的最短时间。
using namespace std;
int main()
{
    int t,k;
    cin>>t;
    for(k=1;k<=t;k++)
    {
        int n,i,j,count[403];
        memset(count,0,sizeof(count));  //数组初始化        
        cin>>n;
        int a,b,temp;
        for(j=1;j<=n;j++)
        {
            cin>>a>>b;
            a=(a-1)/2;   //走廊数            		 
            b=(b-1)/2;   //走廊数            
         if(a>b)             //将数据写成从小到大排列            
	     	{
                temp=a;
                a=b;
                b=temp;
            }           
            for(i=a;i<=b;i++)   
                            //也就是说每经过某个数的位置时这个位置的次数加一                
            count[i]++;
        }
        int max=count[1];      //初始化     
            for(j=1;j<=200;j++)
            if(max<count[j])    
                            //选取其中最大数值乘10,即当前所用最短时间。                                    
             max=count[j];
            cout<<max*10<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36791466/article/details/84495692
今日推荐