Word Amalgamation (map,字符串排序)

Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2818    Accepted Submission(s): 1354


 

Problem Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words. 

Input

The input contains four parts: 

1. a dictionary, which consists of at least one and at most 100 words, one per line; 
2. a line containing XXXXXX, which signals the end of the dictionary; 
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique. 

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

 

tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX

Sample Output

 

score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******

        本题大意是,给一个字典,再给出几个单词查询,若该单词可以通过各种排列组合后得到一个字典里的单词,那么就输出这个字典里的单词。本题可以统计各个查询单词的各个字母的数量,再与字典里的单词一一对比,但是这种做法比较麻烦而且复杂度较高。另一种做法就是用stl中的sort函数对字典中的字符串进行排序,然后用原单词与排序后的单词建立map映射。再对查询单词排序,与map中的已排序后的value值一一对比,若相等则输出。代码如下:

#include<iostream>
#include<algorithm>
#include<map>
using namespace std;
int main()
{
	string index,word;
	map<string,string> dict;
	while(cin>>word && word!="XXXXXX")
	{
		index=word;
		sort(index.begin(),index.end());
		dict[word]=index;
	}
	while(cin>>word && word!="XXXXXX")
	{
		bool flag=false;
		sort(word.begin(),word.end());
		for(map<string, string>::iterator it = dict.begin(); it != dict.end(); it++)
		{
			if(it->second==word)
			{
				cout<<it->first<<endl;
				flag=true;
			}
		}
		if(!flag)
				cout<<"NOT A VALID WORD"<<endl;
		cout<<"******"<<endl;
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Q_M_X_D_D_/article/details/83688796