Word Reversal 【字符串处理】

Word Reversal

For each list of words, output a line with each word reversed without changing the order of the words.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

Output

For each test case, print the output on one line.

Sample Input

1
  
3
I am happy today
To be or not to be
I want to win the practice contest

Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

题意概括:

  将一段文章里的每一个单词逆置,但单词顺序不变。

解题分析:

  一行一行的读取,读取完后将里边的每一个单词逆置后直接输出。

AC代码:

#include<stdio.h>
#include<string.h>

#define N 1000

void reverse(char *x)
{
    int i, tem, len = strlen(x);
    int n = len/2;
    for(i = 0; i < n; i++){
        tem = x[i];
        x[i] = x[len-1-i];
        x[len-1-i] = tem;
    }
    return ;
}                                                                               

int main()
{
    char str[N], s[N];
    int i, j, k, t, n, len, flag;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);getchar();
        for(i = 0; i < n; i++){
            gets(str);
            len = strlen(str);
            for(j = k = flag = 0; j <= len; j++){
                if(str[j] == ' ' || str[j] == '\0'){
                    s[k] = '\0';
                    reverse(s);
                    if(!flag){
                        printf("%s", s);
                        flag = 1;
                    } 
                    else printf(" %s", s);
                    k = 0;
                    continue;
                }
                s[k++] = str[j];
            }
            printf("\n");
        }
        if(t) printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/k_young1997/article/details/79240794