HDU1113 Word Amalgamation【map+排序】

问题链接:HDU1113 Word Amalgamation

Problem Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

 

Input

The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

 

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

 

Sample Input

 

tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX

 

Sample Output

 

score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******

 

Source

Mid-Central USA 1998

问题分析:这是一个字典问题,用map来实现。把单词作为关键字,把单词中的字符排序作为关键字对应的值。需要注意的是,不同的关键字可能具有相同的值。

#include <iostream>
#include <algorithm>
#include <map>
#include <string>
using namespace std;

////////////ac
int main()
{
	map<string,string> m;
	string key,value;
	while(cin>>key&&key!="XXXXXX")
	{
		value=key;
		sort(value.begin(),value.end());
		m[key]=value;
	}
	while(cin>>value&&value!="XXXXXX")
	{
		sort(value.begin(),value.end());
		bool f=false;
		for(map<string,string>::iterator it=m.begin();it!=m.end();it++)
		{
			if(it->second==value)
			{
				cout<<it->first<<endl;
				f=true;
			}
		}
		if(!f)
		{
			cout << "NOT A VALID WORD" << endl;
		}
		cout<<"******"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/aaaaawyf/article/details/82631182
今日推荐