HDU1113 Word Amalgamation

Word Amalgamation

Problem Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words. 

Input

The input contains four parts: 

1. a dictionary, which consists of at least one and at most 100 words, one per line; 
2. a line containing XXXXXX, which signals the end of the dictionary; 
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and 
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique. 

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp given score refund only trap work earn course pepper part XXXXXX resco nfudre aptr sett oresuc XXXXXX

Sample Output

score ****** refund ****** part tarp trap ****** NOT A VALID WORD ****** course ******

注意的是将开始输入的单词作为值,其唯一排序作为键来标记会导致单词记录不全,因为键只能对应一个值。所以将输入单词的值作为键,其唯一排序作为值来记录!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
using namespace std; 
map<string, string> m;
int main()
{
	string s;
	while (cin >> s)
	{
		if (s == "XXXXXX")
			break;
		string tmp = s;
		sort(s.begin(), s.end());
			m[tmp] = s;
	}
	while (cin >> s)
	{
		int flag = 0;
		if (s == "XXXXXX")
			break;
		sort(s.begin(), s.end());
		for (map<string, string>::iterator it = m.begin(); it != m.end(); it++)
		{
			if (s == it->second)
			{
				cout << it->first << endl;
				flag = 1;
			}
		}
		if (!flag)
			cout << "NOT A VALID WORD" << endl;
		cout << "******" << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/slience_646898/article/details/81197726
今日推荐