HDOJ 2602 Bone Collector(背包问题)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/mml5211314/article/details/49700531

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41716    Accepted Submission(s): 17357


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input

 
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
 
  
14



//简单的背包问题

#include<cstring>
#include<iostream>
#define max(a,b) a>b?a:b
using namespace std;
struct node
{
	int num,val;
};
node str[100100];
int bag[100100];
int main()
{
	int m,n,i,j,t;
	cin>>t; 
	while (t--)
	{
		cin>>m>>n;
		memset(str,0,sizeof(str));
		memset(bag,0,sizeof(bag));
		for (i=0;i<m;i++)
		cin>>str[i].val;
		for (i=0;i<m;i++)
		cin>>str[i].num;
		for (i=0;i<m;i++)
		{
			for (j=n;j>=str[i].num;j--)
			{
				bag[j]=max(bag[j],bag[j-str[i].num]+str[i].val);
			}
		}
		cout<<bag[n];
		cout<<"\n";
	}
	return 0;
}






扫描二维码关注公众号,回复: 4123773 查看本文章


猜你喜欢

转载自blog.csdn.net/mml5211314/article/details/49700531
今日推荐