hihoCoder - 1878 Palindromes (找规律)(2018ICPC北京I)

版权声明:Why is everything so heavy? https://blog.csdn.net/lzc504603913/article/details/83997377

时间限制:1000ms

单点时限:1000ms

内存限制:512MB

描述

Recently, Nvoenewr learnt palindromes in his class.

A palindrome is a nonnegative integer that is the same when read from left to right and when read from right to left. For example, 0, 1, 2, 11, 99, 232, 666, 998244353353442899 are palindromes, while 10, 23, 233, 1314 are not palindromes.

Now, given a number, Nvoenewr can determine whether it's a palindrome or not by using loops which his teacher has told him on the class. But he is now interested in another question: What's the K-th palindrome? It seems that this question is too difficult for him, so now he asks you for help.

Nvoenewr counts the number from small to big, like this: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 11, 22, 33, 44, 55, 66, 77, 88, 99, 101 and so on. So the first palindrome is 0 and the eleventh palindrome is 11 itself.
Nvoenewr may ask you several questions, and the K may be very big.

输入

The first line contains one integer T(T <= 20) —— the number of questions that Nvoenewr will ask you.

Each of the next T lines contains one integer K. You should find the K-th palindrome for Nvoenewr.

Let's say K is a n-digit number. It's guaranteed that K >= 1, 1 <= n <= 100000 and the sum of n in all T questions is not greater than 1000000.

输出

Print T lines. The i-th line contains your answer of Nvoenewr's i-th question.

样例输入

4
1
10
11
20

样例输出

0
9
11
101

解题思路:找规律即可。我们暴力打印前几万项,然后一眼就能发现规律了。

N跟答案S,是有规律的。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
string S;
int main()
{
    int T;
    string ans;
    scanf("%d",&T);
    while (T--){
        cin >> S;
        ans.clear();
        int len=S.length();
        if (len==1){
            cout << S[0]-1-'0'<< endl;
            continue;
        }
        if (S=="10"){
            cout << 9 << endl;
            continue;
        }
        if (S[0]=='1'){
            if (S[1]!='0'){
                for (int i=1;i<len;i++){
                    ans.push_back(S[i]);
                }
                for (int i=len-1;i>=1;i--){
                    ans.push_back(S[i]);
                }
            }
            else{
                ans.push_back('9');
                for (int i=2;i<len;i++){
                    ans.push_back(S[i]);
                }
                for (int i=len-2;i>=2;i--){
                    ans.push_back(S[i]);
                }
                ans.push_back('9');
            }
        }
        else{
            ans.push_back(S[0]-1);
            for (int i=1;i<len;i++){
                ans.push_back(S[i]);
            }
            for (int i=len-2;i>=1;i--){
                ans.push_back(S[i]);
            }
            ans.push_back(S[0]-1);
        }
        cout << ans << endl;
    }
}

猜你喜欢

转载自blog.csdn.net/lzc504603913/article/details/83997377