Single Source Shortest Path I (dijkstra()算法邻接表转化为邻接矩阵求最短路)

Single Source Shortest Path

For a given weighted graph $G = (V, E)$, find the shortest path from a source to each vertex. For each vertex $u$, print the total weight of edges on the shortest path from vertex $0$ to $u$.

Input

In the first line, an integer $n$ denoting the number of vertices in $G$ is given. In the following $n$ lines, adjacency lists for each vertex $u$ are respectively given in the following format:

$u$ $k$ $v_1$ $c_1$ $v_2$ $c_2$ ... $v_k$ $c_k$

Vertices in $G$ are named with IDs $0, 1, ..., n-1$. $u$ is ID of the target vertex and $k$ denotes its degree. $v_i (i = 1, 2, ... k)$ denote IDs of vertices adjacent to $u$ and $c_i$ denotes the weight of a directed edge connecting $u$ and $v_i$ (from $u$ to $v_i$).

Output

For each vertex, print its ID and the distance separated by a space character in a line respectively. Print in order of vertex IDs.

Constraints

  • $1 \leq n \leq 100$
  • $0 \leq c_i \leq 100,000$
  • $|E| \leq 10,000$
  • All vertices are reachable from vertex $0$

Sample Input 1

5
0 3 2 3 3 1 1 2
1 2 0 2 3 4
2 3 0 3 3 1 4 1
3 4 2 1 0 1 1 4 4 3
4 2 2 1 3 3

Sample Output 1

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=101;
const int inf=0x3f3f3f;
int n;
int e[maxn][maxn];
int d[maxn];//权值最小的边权
int vis[maxn];//访问状态
void dijkstra()
{
    for(int i=0; i<n; i++)
        d[i]=inf;
    memset(vis,0,sizeof(vis));
    d[0]=0;
    while(1)
    {
        int v=-1;
        int ans=inf;
        for(int i=0; i<n; i++)
        {
            if(ans>d[i]&&!vis[i])
            {
                v=i;
                ans=d[i];
            }
        }
        if(v==-1)break;
        vis[v]=1;
        for(int i=0; i<n; i++)
        {
            if(!vis[i]&&d[i]>e[v][i]+d[v]&&e[v][i]!=inf)
            {
                d[i]=e[v][i]+d[v];
            }
        }
    }
    for(int i=0; i<n; i++)
        if(d[i]==inf)
            printf("%d -1\n",i);
        else printf("%d %d\n",i,d[i]);

}
int main()
{
    cin>>n;
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
        {
            e[i][j]=inf;
        }
    int k,c,u,v;
    for(int i=0; i<n; i++)
    {
        cin>>u>>k;
        for(int j=0; j<k; j++)
        {
            cin>>v>>c;
            e[u][v]=c;
        }
    }
    dijkstra();

    return 0;
}
0 0
1 2
2 2
3 1
4 3

Reference

Introduction to Algorithms, Thomas H. Cormen, Charles E. Leiserson, Ronald L. Rivest, and Clifford Stein. The MIT Press.

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/83930215
今日推荐