HDU 5533 Dancing Stars on Me

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2827    Accepted Submission(s): 1636

Problem Description

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

Input

The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following nlines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.

Output

For each test case, please output "YES" if the stars can form a regular polygon. Otherwise, output "NO" (both without quotes).

Sample Input

3
3
0 0
1 1
1 0
4
0 0
0 1
1 0
1 1
5
0 0
0 1
0 2
2 2
2 0

Sample Output

NO
YES
NO

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

Recommend

hujie   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443

题解

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std ;

double x[105] ;
double y[105] ;
double z[105] ;
bool check[105] ;

int main(){
    int t ;
    cin >> t ;
    while ( t -- ){
        memset(check, true, sizeof (check) ) ;
        memset(x, 0, sizeof (x) ) ;
        memset(y, 0, sizeof (y) ) ;
        int n ;
        cin >> n ;
        double Xsum = 0 ;
        double Ysum = 0 ;
        for ( int i = 0 ; i < n ; i ++ ){
            cin >> x[i] ;
            cin >> y[i] ;
            Xsum += x[i] ;
            Ysum += y[i] ;
        }
        double M = Xsum / n ;
        double N = Ysum / n ;
        for ( int i = 0 ; i < n ; i ++ ){
            z[i] = sqrt((M - x[i])*(M - x[i]) + (N - y[i])*(N - y[i])) ;
        }
        int flag = 1 ;
        for ( int i = n - 1 ; i > 0 ; i -- ){
            if ( z[i] != z[i-1] ){
                check[i] = false ;
                flag = 0 ;
                break ;
            }
        }
        if ( flag > 0 ){
            cout << "YES" << endl ;
        }
        else{
            cout << "NO" << endl ;
        }
    }
}

猜你喜欢

转载自www.cnblogs.com/Cantredo/p/9944169.html