HDU - 5533 Dancing Stars on Me(几何+思维)

版权声明:欢迎转载 https://blog.csdn.net/l18339702017/article/details/82222060

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2441    Accepted Submission(s): 1406


 

Problem Description

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

 

Input

The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following nlines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1≤T≤300
3≤n≤100
−10000≤xi,yi≤10000
All coordinates are distinct.

 

Output

For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).

 

Sample Input

 

3

3

0 0

1 1

1 0

4

0 0

0 1

1 0

1 1

5

0 0

0 1

0 2

2 2

2 0

 

Sample Output

 

NO

YES

NO

 

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

 

Statistic | Submit | Discuss | Note

题意:给出n个点的坐标,问这n个点能否组成正凸多边形。

思路:暴力枚举所有点之间的距离并且存图,找出最短的边,遍历图,判断最短边的数量是否为 n。

#pragma GCC optimize(2)
#include <bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define line cout<<"-----------------"<<endl;

typedef long long ll;
const int maxn = 1e5+10;
const int MAXN = 1e6+10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const int N = 110;

int n;
struct node{
    double x,y ;
}p[N];
double mp[N][N];
double dis(node a,node b){
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        double minn = 9999999999;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%lf%lf",&p[i].x,&p[i].y);
        for(int i=1;i<=n;i++){
            for(int j=i+1;j<=n;j++){
                mp[i][j] = dis(p[i],p[j]);
                if(minn > mp[i][j])
                    minn = mp[i][j];
            }
        }
        ll cnt = 0;
        for(int i=1;i<=n;i++){
            for(int j=i+1;j<=n;j++){
                if(mp[i][j] == minn)
                    cnt++;
            }
        }
        if(cnt == n) puts("YES");
        else puts("NO");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/l18339702017/article/details/82222060