【HDU - 2642】【Stars】

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 2428    Accepted Submission(s): 1006


 

Problem Description

Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.

 

Input

The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.

 

Output

For each query,output the number of bright stars in one line.

 

Sample Input

 

5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200

 

Sample Output

 

1 0

 

Author

teddy

 

Source

百万秦关终属楚

题意:就是问在给定区域内,有多少点亮着的星星

解题思路:二维树状数组 实时更新和求和 利用矩形的计算方法,求出某个区域的值

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn  1009
using namespace std;




int sum[maxn][maxn];

int lowbit(int x)
{
	return x&-x;
}
int sm(int x,int y)
{
	int ans=0;
	for(int i=x;i>0;i-=lowbit(i))
		for(int j=y;j>0;j-=lowbit(j))
		{
			ans+=sum[i][j];
		}
	return ans;
}
void updata(int x,int y,int val)
{
	for(int i=x;i<=maxn;i+=lowbit(i))
		for(int j=y;j<=maxn;j+=lowbit(j))
		{
			sum[i][j]+=val;
		}
}
int  get_val(int i,int j)
{
	int ans= sm(i,j)-sm(i-1,j)-sm(i,j-1)+sm(i-1,j-1);
	return ans;
}
int main()
{
	int m;
	memset(sum,0,sizeof(sum));
	char s[5];
	int ans=0;
	cin>>m;
	int x1,y1,x2,y2;
	while(m--)
	{
		scanf("%s",s);
		if(s[0]=='B')
		{
			scanf("%d%d",&x1,&y1);
			x1++;
			y1++;
			if(get_val(x1,y1)==0)
				updata(x1,y1,1);	
		}	
		if(s[0]=='D')
		{
			scanf("%d%d",&x1,&y1);
			x1++;
			y1++;
			if(get_val(x1,y1)==1)
				updata(x1,y1,-1);
		}
		if(s[0]=='Q')
		{
			scanf("%d%d%d%d",&x1,&x2,&y1,&y2);
			if(x1>x2) swap(x1,x2);
			if(y1>y2) swap(y1,y2);
			x1++,y1++,x2++,y2++;
			ans=sm(x2,y2)-sm(x1-1,y2)-sm(x2,y1-1)+sm(x1-1,y1-1);
			printf("%d\n",ans);
		}	
	}	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/81531262