POJ - 3264 G - Balanced Lineup 区间最值

Balanced Lineup
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 60899   Accepted: 28494
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver


区间最值

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn = 5e4+10;
ll arr[maxn];
struct SegTree
{
    ll Max[maxn<<2],Min[maxn<<2];
    void init() {
        memset(Max,0,sizeof(Max));
        memset(Min,0,sizeof(Min));
    }
    void push_up(int rt) {
        Max[rt] = max(Max[rt<<1],Max[rt<<1|1]);
        Min[rt] = min(Min[rt<<1],Min[rt<<1|1]);
    }
    void build(ll arr[],int l,int r,int rt) {
        if(l == r) {
            Min[rt] = Max[rt] = arr[l];
            return;
        }
        int mid = (l + r) >> 1;
        build(arr,l,mid,rt<<1);
        build(arr,mid+1,r,rt<<1|1);
        push_up(rt);
    }
    ll Max_query(int ql,int qr,int l,int r,int rt) {
        if(ql == l && qr == r)  return Max[rt];
        
        int mid = (l + r) >> 1;
        if(qr <= mid) return Max_query(ql,qr,l,mid,rt<<1);
        if(ql > mid) return Max_query(ql,qr,mid+1,r,rt<<1|1);
        return max(Max_query(ql,mid,l,mid,rt<<1),Max_query(mid+1,qr,mid+1,r,rt<<1|1));
    }
    ll Min_query(int ql,int qr,int l,int r,int rt) {
        if(ql == l && qr == r)  return Min[rt];
        
        int mid = (l + r) >> 1;
        if(qr <= mid) return Min_query(ql,qr,l,mid,rt<<1);
        if(ql > mid) return Min_query(ql,qr,mid+1,r,rt<<1|1);
        return min(Min_query(ql,mid,l,mid,rt<<1),Min_query(mid+1,qr,mid+1,r,rt<<1|1));
    }
}seg;
int main()
{
    int n,q;
    while(~scanf("%d%d",&n,&q))
    {
        int l,r;
        for(int i=1;i<=n;i++) scanf("%lld",&arr[i]);
        seg.build(arr,1,n,1);
        while(q--) {
            scanf("%d%d",&l,&r);
            printf("%lld\n",seg.Max_query(l,r,1,n,1) - seg.Min_query(l,r,1,n,1));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_38013346/article/details/80356042