dfs POJ 2386

                                                        Lake Counting

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 46018   Accepted: 22739

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

#include<iostream>//将扫描到的W设置为. 是主要思想
using namespace std;
int n, m;
char x[100][100];
void dfs(int i, int j) {
	x[i][j] = '.';
	for (int a = -1; a <= 1; a++) {
		for (int b = -1; b <= 1; b++) {
			if (i + a < 0 || i + a >= n || j + b < 0 || j + b >= m)
				continue;
			if (x[i + a][j + b] == 'W') {
				dfs(i + a, j + b);
			}
		}
	}
}

int main() {
	cin >> n >> m;
	int cnt = 0;
	for (int i = 0; i < n; i++)
		for (int j = 0; j < m; j++)
			cin >> x[i][j];
	int i, j;
	for (i = 0; i < n; i++) {
		for (j = 0; j < m; j++) {
			if (x[i][j] == 'W') {
				dfs(i, j);
				cnt++;
			}
		}
	}
	cout << cnt;
 	return 0;
}

猜你喜欢

转载自blog.csdn.net/albert48/article/details/83449319