One-Dimensional Maze(ZOJ)

                                            One-Dimensional Maze

BaoBao is trapped in a one-dimensional maze consisting of grids arranged in a row! The grids are numbered from 1 to from left to right, and the -th grid is marked with a character , where is either 'L' or 'R'.

Starting from the -th grid, BaoBao will repeatedly take the following steps until he escapes the maze:

  • If BaoBao is in the 1st grid or the -th grid, then BaoBao is considered to arrive at the exit and thus can escape successfully.
  • Otherwise, let BaoBao be in the -th grid. If , BaoBao will move to the -th grid; If , Baobao will move to the -th grid.

Before taking the above steps, BaoBao can change the characters in some grids to help himself escape. Concretely speaking, for the -th grid, BaoBao can change from 'L' to 'R', or from 'R' to 'L'.

But changing characters in grids is a tiring job. Your task is to help BaoBao calculate the minimum number of grids he has to change to escape the maze.

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers and (, ), indicating the number of grids in the maze, and the index of the starting grid.

The second line contains a string () consisting of characters 'L' and 'R'. The -th character of indicates the character in the -th grid.

It is guaranteed that the sum of over all test cases will not exceed .

Output

For each test case output one line containing one integer, indicating the minimum number of grids BaoBao has to change to escape the maze.

Sample Input

3
3 2
LRL
10 4
RRRRRRRLLR
7 4
RLLRLLR

Sample Output

0
2
1

Hint

For the first sample test case, BaoBao doesn't have to change any character and can escape from the 3rd grid. So the answer is 0.

For the second sample test case, BaoBao can change to 'R' and to 'R' and escape from the 10th grid. So the answer is 2.

For the third sample test case, BaoBao can change to 'L' and escape from the 1st grid. So the answer is 1.

题目链接:

https://vjudge.net/problem/ZOJ-3992

题意描述:

给你一个长度为n的字符串迷宫,然后给你一个被困的位置,该位置为第几个字母,如果向右走则L为墙,如果向左走R为墙,问向那个方向走穿过的墙少,到达迷宫的边缘时则认为走出迷宫边缘即为字符串的首字符和尾字符

解题思路:

把这些字符存在一个字符串中,然后从第m个字符开始向两个方向走,最后输出穿过墙数较少的方向的墙的数目

程序代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
char str[100010];

int main()
{
	int i,j,T,n,m,sum1,sum2;
	
	scanf("%d",&T);
	while(T--)
	{
		sum1=0;
		sum2=0;
		scanf("%d%d",&n,&m);
		scanf("%s",str);
		for(i=m-1;i<n-1;i++)
			if(str[i]!='R')
				sum1++;
		for(i=m-1;i>0;i--)
			if(str[i]!='L')
				sum2++;
		printf("%d\n",min(sum1,sum2));
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/83385214
ZOJ