POJ1118 Lining Up(暴力+向量叉乘判断共线)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/83044769

Lining Up

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

大意:给出n个点,判断共线的点最多有多少个。

题解:直接暴力求解,用向量叉乘法判断共线提高精确度。

#include<iostream>
#include<cstdio>
using namespace std;
typedef struct{
	int x,y;
}point;
int main()
{
	int i,j,k,n;
	while(cin>>n&&n)
	{
		point a[705];
		for(i=0;i<n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);
		int ans=0;
		for(i=0;i<n;i++)		
			for(j=i+1;j<n;j++)
			{
				int max=2;
				for(k=j+1;k<n;k++)
					if((a[i].x-a[j].x)*(a[j].y-a[k].y)==(a[j].x-a[k].x)*(a[i].y-a[j].y))
						max++;
				if(ans<max) ans=max;
			}
		cout<<ans<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/83044769