poj 1118 Lining Up(暴力+数学)

Lining Up

Time Limit: 2000MS   Memory Limit: 32768K
Total Submissions: 22296   Accepted: 7040

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient! 

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3
题意:给你一个数n,代表在二维空间内的n的点,找到在一条直线上最多的点能有多少。
在空间内的三个点共线,满足(y1-y2)/ (x1-x2)==(y3-y4)/ (x3-x4) ,为了防止分母为0,化成(y1-y2)*(x3-x4)== (x1-x2)*(y3-y4)。用三重循环即可。
#include<cstdio>
#include <algorithm>  
#include <cstring> 
#define LL long long
using namespace std;
struct Node
{
	int x,y;
}a[705];
int main()
{
	int n;
	while(scanf("%d",&n)&&n)
	{
		for(int i=0;i<n;i++)
		   scanf("%d%d",&a[i].x,&a[i].y);
		int sum=0;
		for(int i=0;i<n-2;i++)
		{
			for(int j=i+1;j<n-1;j++)
			{
				int ans=2;
				for(int k=j+1;k<n;k++)
				{
					if((a[i].x-a[j].x)*(a[k].y-a[j].y)==(a[i].y-a[j].y)*(a[k].x-a[j].x))
					    ans++;
				}
				if(ans>sum)
				   sum=ans;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


 

猜你喜欢

转载自blog.csdn.net/qq_35634181/article/details/60762598
今日推荐