NCSTOJ 1418 : SnowflakeSnowSnowflakes

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zhaohaibo_/article/details/83065493

题目描述


[poj3349] You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

输入


The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

输出


If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

样例输入


2
1 2 3 4 5 6
4 3 2 1 6 5

样例输出


Twin snowflakes found.

两个雪花相同,每一个角的和与积要相同,顺逆时针的遍历也应相同。
可以定义snow[100000][6]存储所有的雪花。
n条数据查找的时间复杂度为O(n^2)

使用哈希表存储,对于随机数据期望的时间复杂度为O(n^2/P);取P为最接近N的质数,期望的时间复杂度为O(N)。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
const int SIZE = 100010;
int n, tot, P = 99991;
int snow[SIZE][6], head[SIZE], Next[SIZE];

int H(int *a) {
    int sum = 0, mul = 1;
    for (int i = 0; i < 6; i++) {
        sum = (sum + a[i]) % P;
        mul = (long long)mul * a[i] % P;
    }
    return (sum + mul) % P;
}

bool equal(int *a, int *b) {
    for (int i = 0; i < 6; i++)
        for (int j = 0; j < 6; j++) {
            bool eq = 1;
            for (int k = 0; k < 6; k++)
                if (a[(i+k)%6] != b[(j+k)%6]) eq = 0;
            if (eq) return 1;
            eq = 1;
            for (int k = 0; k < 6; k++)
                if (a[(i+k)%6] != b[(j-k+6)%6]) eq = 0;
            if (eq) return 1;
        }
    return 0;
}

bool insert(int *a) {
    int val = H(a);
    // 遍历表头head[val]指向的链表,寻找形状相同的雪花
    for (int i = head[val]; i; i = Next[i]) {
        if (equal(snow[i], a)) return 1;
    }
    // 未找到形状相同的雪花,执行插入
    ++tot;
    memcpy(snow[tot], a, 6 * sizeof(int));
    Next[tot] = head[val];
    head[val] = tot;
    return 0;
}

int main() {
    cin >> n;
    for (int i = 1; i <= n; i++) {
        int a[10];
        for (int j = 0; j < 6; j++) scanf("%d", &a[j]);
        if (insert(a)) {
            puts("Twin snowflakes found.");
            return 0;
        }
    }
    puts("No two snowflakes are alike.");
}

猜你喜欢

转载自blog.csdn.net/zhaohaibo_/article/details/83065493