北大 Poj 1083

Moving Tables

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 34320   Accepted: 11447

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 


The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 


For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 

Sample Output

10
20
30

Source

Taejon 2001


移动桌子问题。

开始这一题我想错了,认为每次输入后将新区间与之前的区间进行对比来算出区间的重复值,但是这样可能导致一些并行区间被与某区间重叠部分重复计算,而要消去这些重叠部分又难以做到,所以这个思路是错误的。下面PO一下错误的代码。。请勿模仿

#include<iostream>

using namespace std;
int main(void){
    int number,count,i(0),s,t,time(0),j(0);
    cin>>number;
    int Time[200];
    while(j<number){
        cin>>count;
        int a[200]={0};
        i=0;
        while(i<2*count){
            cin>>s>>t;
            if(s<=t){
                a[i]=s;
                a[i+1]=t;
            }
            else{
                a[i+1]=s;
                a[i]=t;
            }
            i+=2;
        }
        time=0;
        for(i=1;i<2*count-1;i+=2){
            if(a[i]>(a[i+1])){
                time++;;
            }
        }
        
        time=10+time*10;
        Time[j]=time;
        j++;
    }
    
    for(i=0;i<number;i++){
        cout<<Time[i]<<endl;
    }
    return 0;
}

实际上,只要计算房间前的走廊被重复使用多少次,再找出使用最多的那段走廊,将其使用次数乘以10就是最终答案。注意一些前期工作要做好,比如始终将移动区间的左值设为奇数,右值设为偶数,因为[4,7]区间是等价于[3,8]区间的,然后让左值始终小于右值,这样做是为了之后统计房间前走廊使用次数方便。 

下面是正确思路代码。

  • 这里用 memset(room,0,sizeof(room)); 进行初始化。(用 room[401]={0}; 会warning )
  • 直接用swap函数交换两数位置
  • sort排序(在北大的oj上需加 #include<algorithm> 头文件)
#include<iostream>
#include<algorithm>
using namespace std;
struct 
{
	int left,right;
}Move[210];
int room[401];
int main()
{
	int i,j,num,test,time;
	cin>>test;
	while(test--)
	{
		time=-1;
		memset(room,0,sizeof(room));
		for(i=0;i<210;i++)
			Move[i].left=Move[i].right=0;
		cin>>num;
		for(i=1;i<=num;i++)
		{
			cin>>Move[i].left>>Move[i].right;
			if(Move[i].left>Move[i].right)
				swap(Move[i].left,Move[i].right);
			if(Move[i].right%2)
				if(Move[i].left%2)
				Move[i].right+=1;
				else
				{Move[i].right+=1;Move[i].left-=1;}
			else if((Move[i].left%2)==0)
				Move[i].left-=1;
			for(j=Move[i].left;j<=Move[i].right;j++)
					room[j]++;
		}
		//for(i=1;i<=400;i++)
		//	if(time<room[i])
		//		time=room[i];
        //cout<<time*10<<endl;
        sort(room,room+401);
		cout<<room[400]*10<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36770641/article/details/82974434