COURSES POJ1469(模板)

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

题解:

标准的匈牙利算法,最需要最后的匹配树等于课程数,我感觉最大流也是可以写的。

#include <cstring>
#include <cstdio>
using namespace std;
const int MAXN=50005;
struct node{
    int v,next;
}edge[MAXN];
int cnt=0,head[MAXN];
int p,n;
void add(int x,int y)
{
    edge[cnt].v=y;
    edge[cnt].next=head[x];
    head[x]=cnt++;
}
int ans=0;
bool vis[MAXN];
int match[MAXN];
bool findpath(int x)
{
    for (int i = head[x]; i !=-1 ; i=edge[i].next) {
        int v=edge[i].v;
        if(!vis[v])
        {
            vis[v]=true;
            if(match[v]==-1||findpath(match[v]))
            {
                match[v]=x;
                return true;
            }
        }
    }
    return false;
}
void hungry()
{
    for (int i = 1; i <=p; ++i) {
        memset(vis,false, sizeof(vis));//没次都去初始化
        if(findpath(i))//寻找是否有增广路
            ans++;
    }
}
int main()
{
    int _;
    scanf("%d",&_);
    while(_--)
    {
        cnt=0;
        ans=0;
        memset(head,-1, sizeof(head));
        memset(match,-1, sizeof(match));
        memset(vis,false, sizeof(vis));
        scanf("%d%d",&p,&n);
        int num,x;
        for (int i = 1; i <=p ; ++i) {
            scanf("%d",&num);
            while(num--)
            {
                scanf("%d",&x);
                add(i,x);
            }
        }
        hungry();
        if(ans==p)
            printf("YES\n");
        else
            puts("NO");
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/-xiangyang/p/9825832.html