POJ 2239 Selecting Courses (二分图)

版权声明:Nicolas https://blog.csdn.net/qq_42835910/article/details/85346029

Selecting Courses

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11797   Accepted: 5246

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects. 

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him? 

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

Source

POJ Monthly,Li Haoyuan

#include <iostream>
#include <cstring>
using namespace std; 
#define N 301
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int e[N][85];
int courseNum;
bool use[N];
int match[N];
//深度优先搜索匹配课程更新 
bool dfs(int u){
	for(int i=0;i<=84;i++){
		if(!use[i] && e[u][i]){
			use[i]=true;
			if(match[i]==-1 || dfs(match[i])){
				match[i]=u;
				return true;
			}
		}
	}
	return false;
}

int Hungary(){
	int sum=0;
	for(int i=0;i<=courseNum;i++){
		memset(use,0,sizeof(use));
		if(dfs(i))
			sum++;
	}
	return sum;
}

int main(int argc, char** argv) {
	while(cin>>courseNum){
		int t;
		
		memset(e,0,sizeof(e));
		memset(match,-1,sizeof(match));
		for(int i=1;i<=courseNum;i++){
			cin>>t;
			while(t--){
				int p,q;
				cin>>p>>q;
				e[i][(p-1)*12+q]=1;				
			}
		}
		cout<<Hungary()<<endl;		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42835910/article/details/85346029
今日推荐