【HDU - 1045】Fire Net (dfs 或二分图)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/83099706

题干:

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

解题报告:

      这题水啊,数据范围4*4,比赛的时候直接dfs一发。找准dfs定义的状态的含义,不难写,有点类似八皇后的递归思路。

     二分图显然要把原始图分别按行和列缩点。建图:横竖分区。同一列相连的空地同时看成一个点,显然这样的区域不能够同时放两个点。这些点作为二分图的X部。同理在对所有的行用相同的方法缩点,作为Y部。

     连边的条件是两个区域有相交部分(即'.'的地方)。最后求最大匹配就是答案。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int n,ans;
char maze[10][10];
bool bk[10][10];
bool ok(int x,int y) {
	for(int i = x; i>=1; i--) {
		if(maze[i][y] == 'X') break;
		if(bk[i][y] == 1) return 0;
	}
	for(int i = y; i>=1; i--) {
		if(maze[x][i] == 'X') break;
		if(bk[x][i] == 1) return 0;
	}
	return 1;
}
void dfs(int x,int y,int cur) {
	if(x == n && y == n) {
		if(maze[x][y] == '.' &&ok(x,y)) cur++;
		ans = max(ans,cur);
		return ;
	}
	if(y == n) {
		if(maze[x][y] == '.' && ok(x,y)) {
			bk[x][y]=1;
//			make(x,y);
			dfs(x+1,1,cur+1);
			bk[x][y]=0;
		}
		dfs(x+1,1,cur);
	}
	else {
		if(maze[x][y] == '.' && ok(x,y)) {
			bk[x][y]=1;
			dfs(x,y+1,cur+1);
			bk[x][y]=0;
		}
		dfs(x,y+1,cur);
	}
	
}
int main() 
{
	while(~scanf("%d",&n) ) {
		if(n == 0) break;
		memset(bk,0,sizeof bk);
		ans=0;
		for(int i = 1; i<=n; i++) {
			scanf("%s",maze[i]+1);
		}
		dfs(1,1,0);
		printf("%d\n",ans);		
	}

	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/83099706