dfs 深搜---hdu-1045-Fire Net

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14476    Accepted Submission(s): 8751


 

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

 

Sample Input

扫描二维码关注公众号,回复: 2304378 查看本文章

4

.X..

....

XX..

....

2

XX

. X

3

. X .

X . X

. X .

3

. . .

.XX

.XX

4

....

....

....

....

0

Sample Output

5

1

5

2

4

Source

Zhejiang University Local Contest 2001

 题意:给一张地图,点 代表空地,X 代表墙,在 点 上可以建炮台,条件是 在同一横同一列最多只能建一个炮台(除非两个炮台             之间有墙相隔),问最多可以建多少个炮台?

题解:dfs深搜,参考 https://www.cnblogs.com/pangblog/p/3294053.html

​
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,ans=0;
char s[10][10];

void dfs(int sum){    // 为此从最左上角开始递归 
	if(sum>ans){
		ans=sum;
	}
	
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			if(s[i][j]=='.'){
				int leap=0;
				for(int k=0;k<4;k++){
					int xx=i,yy=j;
					while(1){
						if(k==0){
							xx=xx+1;
							yy=yy+0;
						}
						else if(k==1){
							xx=xx-1;
							yy=yy+0;
						}
						else if(k==2){
							xx=xx+0;
							yy=yy+1;
						}
						else if(k==3){
							xx=xx+0;
							yy=yy-1;
						}
						if(xx<0||yy<0||xx>=n||yy>=n||s[xx][yy]=='X')
						   break;
						else if(s[xx][yy]=='P'){
							leap=1;
							break;
						}
				    }
				}
				if(!leap){
					s[i][j]='P';
					dfs(sum+1);    // 递归 直到在第一个位置放置炮台这个搜索结束 
				/*	PX..
					....
					XX..
					....  */	
					s[i][j]='.';   // 第一个位置不放置炮台又执行循环体下一个为空地的点 
				/*	.X..
					....
					XX..
					....  */
			    }
			}
		}
	}
}

int main(){
	while(scanf("%d",&n),n){
		for(int i=0;i<n;i++)
		  scanf(" %s",s[i]);
		ans=0;
		dfs(0);
		printf("%d\n",ans);	
	}
	return 0;
}

​

猜你喜欢

转载自blog.csdn.net/black_horse2018/article/details/81122295
今日推荐