HDU - 1045 Fire Net【离散化+二分图匹配】

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14174    Accepted Submission(s): 8577


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
 
  
4.X......XX......2XX.X3.X.X.X.X.3....XX.XX4................0
 

Sample Output
 
  
51524

思路:

可以对每一个连续的横块和竖块编号。这样,一个点可以表示为所在横块的编号对所在竖块的编号的连边。由于连续的快编号是唯一的,这样可以保证选取一个点之后,所在横块和竖块不会再匹配第二个点。建完图后,直接跑二分图最大匹配就行了。

可以参见博客:https://blog.csdn.net/acdreamers/article/details/8654005

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define MAXN 110
int k,n,m;
int match[MAXN];
bool used[MAXN];
char G[MAXN][MAXN];
vector<int> vec[MAXN];
int row[MAXN][MAXN],col[MAXN][MAXN],vis[MAXN][MAXN],xx,yy;
bool find(int u)
{
    for(int i=0;i<vec[u].size();i++)
    {
        int v=vec[u][i];
        if(!used[v])
        {
            used[v]=1;
            if(match[v]==-1 || find(match[v]))
            {
                match[v]=u;
                return true;
            }
        }
    }
    return false;
}
int hungry()
{
    int ans=0;
    for(int i=0;i<=xx;i++)
    {
        memset(used,0,sizeof used);
        if(find(i)) ans++;
    }
    return ans;
}
int main()
{
    while(scanf("%d",&n) && n)
    {
        for(int i=0;i<n;i++)
            scanf("%s",G[i]);
        for(int i=0;i<=20;i++)
            vec[i].clear();
        xx=1,yy=1;
        memset(row,0,sizeof row);
        memset(col,0,sizeof col);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(G[i][j]=='.' && row[i][j]==0)
                {
                    for(int p=j;p<n && G[i][p]=='.';p++)
                        row[i][p]=xx;
                    xx++;
                }
                if(G[i][j]=='.' && col[i][j]==0)
                {
                    for(int p=i;p<n && G[p][j]=='.';p++)
                        col[p][j]=yy;
                    yy++;
                }
            }
        }
        memset(vis,0,sizeof vis);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(G[i][j]=='.' && !vis[row[i][j]][col[i][j]])
                {
                    vis[row[i][j]][col[i][j]]=1;
                    vec[row[i][j]].push_back(col[i][j]);
                }
            }
        }
        memset(match,-1,sizeof match);
        printf("%d\n",hungry());
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/u013852115/article/details/80348023