HDU - 1045 Fire Net (二分图 + 缩点)

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

 

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

题意:

要求在某些位置放置导弹,导弹能攻击同行同列的导弹,但是导弹不可以穿过墙壁,求最多可以放多少个导弹

思路:

预处理地图中连通的行和列,把连通的行缩为1个点,把连通的列缩为一个点,当mp[i][j] == '.'时将该行该列对应的点连一条边,然后二分图匹配,最大匹配数即最多导弹数

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const int N = 110;

int linker[N], g[N][N];
bool vis[N];
int a[N][N], b[N][N];
int n, un, vn;
string s[N];

bool dfs(int u) {
    for(int v = 1; v <= vn; ++v) {
        if(g[u][v] && !vis[v]) {
            vis[v] = 1;
            if(linker[v] == -1 || dfs(linker[v])) {
                linker[v] = u;
                return 1;
            }
        }
    }
    return 0;
}

int hungary() {
    int res = 0;
    memset(linker, -1, sizeof(linker));
    for(int u = 1; u <= un; ++u) {
        memset(vis, 0, sizeof(vis));
        if(dfs(u)) res++;
    }
    return res;
}

int main() {
    while(~scanf("%d", &n) && n){
        for(int i = 1; i <= n; ++i) {
            cin >> s[i];
            s[i] = "#" + s[i];
        }
        un = vn = 1;
        memset(g, 0, sizeof(g));
        memset(a, -1, sizeof(a));
        memset(b, -1, sizeof(b));
        for(int i = 1; i <= n; ++i) {
            for(int j = 1; j <= n; ++j) {
                if(s[i][j] == '.' && a[i][j] == -1) {
                    for(int k = i; k <= n && s[k][j] == '.'; ++k)
                        a[k][j] = vn;
                    ++vn;
                }
            }
        }
        for(int i = 1; i <= n; ++i) {
            for(int j = 1; j <= n; ++j) {
                if(s[i][j] == '.' && b[i][j] == -1) {
                    for(int k = j; k <= n && s[i][k] == '.'; ++k)
                        b[i][k] = un;
                    ++un;
                }
            }
        }
        for(int i = 1; i <= n; ++i) {
            for(int j = 1; j <= n; ++j) {
                if(s[i][j] == '.')
                    g[a[i][j]][b[i][j]] = g[b[i][j]][a[i][j]] = 1;
            }
        }
        un--, vn--;
        int ans = hungary();
        printf("%d\n", ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43871207/article/details/109208232