POJ - 2301(水题)

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.
Given the winning numbers for each type of bet, can you deduce the final scores?
Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing “impossible”. Recall that football scores are always non-negative integers.
Sample Input
2
40 20
20 40
Sample Output
30 10
impossible

  • 题目大意:
    给你两个数n,m
    a+b=n |a-b|=m,能不能找出这么俩数。能就输出a b不能就输出impossible.
  • 思路:
    在这里插入图片描述
    就一个二元一次方程组,a=(n+m)/2,b=(n-m)/2;
    有几个条件 n<m 肯定就无解了,然后就是a>=b>0,还有就是都得是整数,所以(n+m)%2==0.
  • 代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
	int n,m;
	int T;
	cin>>T;
	int a,b; 
	while(T--)
	{
		cin>>n>>m;
		a=(m+n)/2;
		b=(n-m)/2; 
		if(n<m||(m+n)%2!=0)
			cout<<"impossible"<<endl;
		else
			cout<<a<<" "<<b<<endl;
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_43179892/article/details/83722410
今日推荐