hdu 6430 bitset _Find_first

Problem E. TeaTree
Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 968 Accepted Submission(s): 367

Problem Description
Recently, TeaTree acquire new knoledge gcd (Greatest Common Divisor), now she want to test you.
As we know, TeaTree is a tree and her root is node 1, she have n nodes and n-1 edge, for each node i, it has it’s value v[i].
For every two nodes i and j (i is not equal to j), they will tell their Lowest Common Ancestors (LCA) a number : gcd(v[i],v[j]).
For each node, you have to calculate the max number that it heard. some definition:
In graph theory and computer science, the lowest common ancestor (LCA) of two nodes u and v in a tree is the lowest (deepest) node that has both u and v as descendants, where we define each node to be a descendant of itself.

Input
On the first line, there is a positive integer n, which describe the number of nodes.
Next line there are n-1 positive integers f[2] ,f[3], …, f[n], f[i] describe the father of node i on tree.
Next line there are n positive integers v[2] ,v[3], …, v[n], v[i] describe the value of node i.
n<=100000, f[i] < i, v[i]<=100000

Output
Your output should include n lines, for i-th line, output the max number that node i heard.
For the nodes who heard nothing, output -1.

Sample Input
4
1 1 3
4 1 6 9

Sample Output
2
-1
3
-1

Source
2018 Multi-University Training Contest 10

Recommend
chendu | We have carefully selected several similar problems for you: 6437 6436 6435 6434 6433

题意,每对数可以把他们的gcd告诉他们最近的公共父亲,问每个点的接收到的最大值。
做法bitset,_Find_first可以找到第一个为1的数,_Find_next可以找到下一个为1的数。

#include<bits/stdc++.h>
using namespace std;
const int N = 1e5+7;
vector<int> G[N];
int num[N];
int ans[N];
void update(int x,bitset<N> &b){
    for(int i = 1;i * i <= x;i ++){
        if(x % i == 0){
            b[N-i] = 1;
            b[N-x/i] = 1;
        }
    }
}

int get(bitset<N> &a,bitset<N> &b){
    bitset<N> c =a & b;
    return N - c._Find_first();
}

bitset<N> dfs(int x){
    bitset<N> as,bs;
    as.reset();
    bs.reset();
    update(num[x],as);
    int ret = 0;
    for(int i = 0;i < G[x].size();i ++){
        bs = dfs(G[x][i]);
        ret = max(ret,get(as,bs));
        as |= bs;
    }
    if(ret == 0) ret = -1;
    ans[x] = ret;

    return as;
}

int main(){
    int n;
    scanf("%d",&n);
    for(int i =2;i <= n;i ++){
        int now;
        scanf("%d",&now);
        G[now].push_back(i);
    }
    for(int i = 1;i <= n;i ++)scanf("%d",&num[i]);
    dfs(1);
    for(int i = 1;i <= n;i ++)
        printf("%d\n",ans[i]);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/zstu_zy/article/details/82011170