HDU2051Bitset

本文章仅用于笔记。部分知识点来源于网络,授权请联系作者([email protected])。



题目


Give you a number on base ten,you should output it on base two.(0 < n < 1000)
InputFor each case there is a postive number n on base ten, end of file. OutputFor each case output a number on base two. Sample Input
1
2
3
Sample Output
1
10
11


解题


import java.util.Scanner;

public class HDU2051
{
//Bitset 
	public static void main(String[] args)
	{
		Scanner s=new Scanner(System.in);
		while(s.hasNextInt())
		{
			int n=s.nextInt();
			String m="";
			while(n>0)
			{
				m=n%2+m;
				n=n/2;
			}
			System.out.println(m);
		}
	}
}

求来波关注! 谢谢啦0.0!

小小小作者 
@Fanny0602

猜你喜欢

转载自blog.csdn.net/qq_40833874/article/details/78726528
今日推荐