HDU-2051 Bitset

Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

Input

For each case there is a postive number n on base ten, end of file.

Output

For each case output a number on base two.

Sample Input

1

2

3

Sample Output

1

10

11

题意:十进制转化为二进制。

代码:

#include <stdio.h>
 
int main()
{
	int n,i,j,a[100];
	while(scanf("%d",&n)!=EOF)
	{
		i=0;
		while(n)
		{
			a[i]=n%2;
			n=n/2;
			i++;
		}
		for(j=i-1;j>=0;j--)
			printf("%d",a[j]);
		printf("\n");
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81701783