HDU2051_Bitset

Bitset


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21577    Accepted Submission(s): 16009


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
 
  
1 2 3
 

Sample Output
 
  
1 10 11
 

Author
8600 && xhd
 

Source

#include <stdio.h>
int bin[100]={0};
int len=0;

int sub(int x)
{
    if (x!=0)
    {
        bin[len++]=x%2;
        return sub(x/2);
    }
    else
        len--;
}

int main()
{
    int n,i;
    while (scanf ("%d",&n)!=EOF)
    {
        len=0;
        sub(n);
        for (i=len;i>=0;i--)
            printf ("%d",bin[i]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/github_36324732/article/details/53468628