POJ 2312 Battle City ——————BFS

Language:Default
Battle City
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10110 Accepted: 3364

Description

Many of us had played the game “Battle city” in our childhood, and some people (like me) even often play it on computer now. ![这里写图片描述](http://poj.org/images/2312_1.jpg)
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). ![这里写图片描述](http://poj.org/images/2312_2.jpg)
Your tank can’t move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of ‘Y’ (you), ‘T’ (target), ‘S’ (steel wall), ‘B’ (brick wall), ‘R’ (river) and ‘E’ (empty space). Both ‘Y’ and ‘T’ appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can’t arrive at the target, output “-1” instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

Source

POJ Monthly,鲁小石
—– BFS 简单题 —–
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int MAXN=309;
int n,m,stx,sty,edx,edy,ans;
char str[MAXN][MAXN];
bool vis[MAXN][MAXN];
int d[4][2]={0,1, 0,-1, 1,0, -1,0};
struct node{
    int x,y,step;
    node(){};
    node(int _x,int _y,int _step)
    {
        x=_x;y=_y;step=_step;
    }
    bool operator < (const node &b)const
    {
        return step>b.step;
    }
};

void bfs(int x,int y)
{
    memset(vis,0,sizeof(vis));
    priority_queue<node> que;
    node e1,e2;
    vis[x][y]=1;
    que.push(node(x,y,0));
    while(que.size())
    {
        e1=que.top();que.pop();
        if(str[e1.x][e1.y]=='T')
        {
            ans=e1.step;
            break;
        }
        for(int i=0;i<4;i++)
        {
            e2.x=e1.x+d[i][0];
            e2.y=e1.y+d[i][1];
            e2.step=e1.step+1;
            if(!vis[e2.x][e2.y] && 0<= e2.x && e2.x < n && 0 <= e2.y && e2.y <m && str[e2.x][e2.y]!='R' && str[e2.x][e2.y]!= 'S')
            {
                vis[e2.x][e2.y]=1;
                if(str[e2.x][e2.y]=='B') e2.step++;
                que.push(e2);
            }
        }
    }
}


int main()
{
    while(~scanf("%d %d",&n,&m)&&(n|m))
    {
        for(int i=0;i<n;i++)    scanf("%s",str[i]);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                if(str[i][j]=='Y')
                {
                    stx=i;
                    sty=j;
                    break;
                }
            }
        ans=-1;
        bfs(stx,sty);
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/82669865
今日推荐