POJ 2312 Battle City

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 


What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 


Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

本题其实不难,算是标准的板子题,按着BFS广搜模板套就可以了。。。。。。。

题意:Y是你;T是你要去的地方;R、S分别是河流、钢墙,不能通过;B是砖墙需要两次操作才可以过;E是空的一次操作就可以过;求你到达T最少需要几步操作。

解题思路:BFS广搜,把所有可能的情况都走一遍,得出答案。

BFS广搜的关键点:

  1. 方向数组的定义
  2. 优先队列求最优解
  3. 剪枝

AC 代码:

//#include <bits/stdc++.h>
//#include <stdio.h>
//#include <queue>
//#include <iostream>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <functional>
#include <algorithm>
#include <algorithm>
#define _USE_MATH_DEFINES
#define MAXN 300+10
using namespace std;
typedef long long ll;

int n, m;
char str[MAXN][MAXN];
int vis[MAXN][MAXN];

struct stu
{
    int x,y,step;
}e1,e2;

//优先队列的排列方式
bool operator < (stu a, stu b)
{
    return a.step > b.step;
}

int d[4][2]={1, 0, -1, 0, 0, 1, 0, -1};//定义一个表示下一步能走到哪的方向数组

void BFS(int x1, int y1, int x2, int y2)
{
    memset(vis, 0, sizeof(vis));//对VIS赋初值
    e1.x = x1, e1.y = y1, e1.step = 0;
    priority_queue<stu> que;
    que.push(e1);
    vis[x1][y1] = 1;//标记起始点
    int ans = -1;//对ans赋初值
    while(!que.empty())
    {
        e1 = que.top();
        que.pop();
        if(e1.x == x2 && e1.y == y2)
        {
            ans = e1.step;
            break;
        }
        for(int i=0; i<4; i++)
        {
            e2.x = e1.x + d[i][0];
            e2.y = e1.y + d[i][1];
            if(e2.x < 0 || e2.y < 0 || e2.x >= n || e2.y >= m)    continue;//超出范围
            if(vis[e2.x][e2.y] == 1)    continue;//已经走过的点不用再走
            if(str[e2.x][e2.y] == 'S')  continue;//钢墙不能过
            if(str[e2.x][e2.y] == 'R')  continue;//河流不能过
            if(str[e2.x][e2.y] == 'B')  e2.step = e1.step + 2; //砖墙需要两步
            else    e2.step = e1.step + 1;//empty需要一步
            //以上continue的这些情况其实就是剪枝的过程,
            que.push(e2);
            vis[e2.x][e2.y] = 1;//标记该点已经走过
        }
    }
    printf("%d\n", ans);
}



int main()
{
    int stax, stay, enx, eny;
    while(scanf("%d %d", &n, &m) != EOF && (n || m))
    {
        for(int i=0; i<n; i++)
        {
            scanf("%s", str[i]);
        }
        //找到起始位置
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                if(str[i][j] == 'Y')    stax = i , stay = j;
                if(str[i][j] == 'T')    enx = i, eny =j;
            }
        BFS(stax, stay, enx, eny);
    }
    return 0;
}

  the past is everything we were, don't makes us who we are!!!

猜你喜欢

转载自blog.csdn.net/A_B_C_D_E______/article/details/81334983