Battle City

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 


What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 


Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

题意:从Y开始移动,如果遇到S或者R不能通过,如果遇到B则时间加2,如果遇到E则时间加1,求到达T的最短时间;

分析如下:

根据要求这也是一道典型的BFS的模板题,我做这道题的时候有个误区,分享一下:

1.根据样例当y向左移动时首先耗费时间为2,因此根据重载函数,y会向下运动同样也是2,到达(1,1)此时同时都是2,这可怎么办,一直在纠结 ,大概半小时以后,明白原来此时第二种情况已经位于优先队列的上层,所以会执行第一种情况,坦克继续向右移动;

代码如下:

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
#include<cmath>
#include<cstdio>
#define ll long long
using namespace std;
const int MAXN=310;
int a1,b1,mex,mey,tx,ty,flag,r[MAXN][MAXN];
char str[MAXN][MAXN];
int r1[2][4]={{0,0,1,-1},{1,-1,0,0}};
struct node{
    int x,y,step;
    bool friend operator<(node a,node b){
        return a.step>b.step;//重载函数
    }
};

void BFS(int mex,int mey){
    priority_queue<node> p;
    flag=0;
    node now,next;
    now.x=mex;
    now.y=mey;
    now.step=0;
    p.push(now);
    while(!p.empty()){
        next=p.top();
        p.pop();
        if(next.x==tx && next.y==ty){
            flag=1;
            break;
        }
        for(int i=0;i<4;i++){
            now.x=next.x+r1[0][i];
            now.y=next.y+r1[1][i];
            if(now.x>=0 && now.x<a1 && now.y>=0 && now.y<b1 && str[now.x][now.y]!='S' && str[now.x][now.y]!='R' && !r[now.x][now.y]){
                if(str[now.x][now.y]=='B'){
                    now.step=next.step+2;
                }
                else{
                    now.step=next.step+1;
                }
                r[now.x][now.y]=1;
                p.push(now);
            }
        }
    }
    if(flag){
        printf("%d\n",next.step);
    }
    else{
        printf("%d\n",-1);
    }
}
int main(){
    while(scanf("%d%d",&a1,&b1)!=EOF&&(a1||b1)){
        memset(r,0,sizeof(r));
        memset(str,0,sizeof(str));
        for(int i=0;i<a1;i++){
            getchar();
            for(int j=0;j<b1;j++){
                scanf("%c",&str[i][j]);
                if(str[i][j]=='Y'){
                    mex=i;
                    mey=j;
                }
                if(str[i][j]=='T'){
                    tx=i;
                    ty=j;
                }
            }
        }
        BFS(mex,mey);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/liubang00001/article/details/81393134