程序设计基础10 树的遍历问题

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

一,主要思想

    入栈顺序即为先序遍历的顺序,出栈顺序即为中序遍历的顺序,根据进栈1 2 3 4 5 6 和出栈 3 2 4 1 6 5可以确定一个唯一的二叉树。

二,关于输入的写法

   

	scanf("%d", &n);
	for (int i = 0; i < 2 * n; i++) {
		scanf("%s", str);
		if (strcmp(str, "Push") == 0) {
			scanf("%d", &num);
			pre_arr[pre_index++] = num;
			sta.push(num);
		}
		else{
			num = sta.top();
			sta.pop();
			in_arr[in_index++] = num;
		}
	}

即首先利用scanf() 输入字符串时遇到空格等符号时会自动停止输入,然后用strcmp()比较即可。

三,正确代码

#include<cstdio>
#include<string.h>
#include<stack>
using namespace std;
//到17:05
int n = 0;
int times = 0;
int pre_arr[40] = { 0 };
int in_arr[40] = { 0 };
struct node {
	int data;
	node *lchild;
	node *rchild;
};
stack<int> sta;
node *create(int preL,int preR,int inL,int inR) {
	if (preL > preR) {
		return NULL;
	}
	node *root = new node;
	root->data = pre_arr[preL];
	int k;
	for (k = inL; k <= inR; k++) {
		if (pre_arr[preL] == in_arr[k]) {
			break;
		}
	}
	int numLeft = k - inL;
	root->lchild = create(preL + 1, preL + numLeft, inL, k - 1);
	root->rchild = create(preL + numLeft + 1, preR, k + 1, inR);
	return root;
}
void posOrder(node *tree) {
	if (tree == NULL) {
		return;
	}
	posOrder(tree->lchild);
	posOrder(tree->rchild);
	printf("%d", tree->data);
	times++;
	if (times != n) {
		printf(" ");
	}
}
int main() {
	char str[6];
	int num = 0;
	int pre_index = 0;
	int in_index = 0;
	scanf("%d", &n);
	for (int i = 0; i < 2 * n; i++) {
		scanf("%s", str);
		if (strcmp(str, "Push") == 0) {
			scanf("%d", &num);
			pre_arr[pre_index++] = num;
			sta.push(num);
		}
		else{
			num = sta.top();
			sta.pop();
			in_arr[in_index++] = num;
		}
	}
	node *tree = create(0, n - 1, 0, n - 1);
	posOrder(tree);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/82529770