程序设计基础6 队列的一些问题

1056 Mice and Rice(25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

一,正确解法

#include<cstdio>
#include<queue>
using namespace std;
//到9:00
struct mice_and_rice {
	int weight;
	int rank;
}mice[1010];
queue<int> que;
int main() {
	int Np = 0;
	int Ng = 0;
	int num = 0;
	int order = 0;
	scanf("%d %d", &Np, &Ng);
	for (int i = 0; i < Np; i++) {
		scanf("%d", &mice[i].weight);
	}
	for (int i = 0; i < Np; i++) {
		scanf("%d", &order);
		que.push(order);
	}
	int temp = Np;
	int group = 0;
	while (temp != 1) {
		if (temp%Ng == 0)group = temp / Ng;
		else group = temp / Ng + 1;
		for (int i = 0; i < group; i++) {
			int max_mark = que.front();
			for (int j = 0; j < Ng; j++) {
				if (i*Ng + j >= temp)break;
				int front = que.front();
				if (mice[front].weight > mice[max_mark].weight) {
					max_mark = front;
				}
				mice[front].rank = group + 1;
				que.pop();
			}
			que.push(max_mark);
		}
		temp = group;
	}
	mice[que.front()].rank = 1;
	for (int i = 0; i < Np; i++) {
		printf("%d", mice[i].rank);
		if (i != Np - 1) {
			printf(" ");
		}
	}
	return 0;
}

二,总结

当初的困难是如何在队列中对那一个单位的三个体重进行比较,使得既能够把那三个体重分出高下(需要暂时保存它们的值),又能够比较完之后需要把那三个值pop(与暂时保存它们的值矛盾?),同时又有如果一组中有两个甚至三个相等的值怎么办(事实上题干给出了这些值各不相等,未认真读题)。

解决方法是不必把那三个体重比出高下,只需要把它们归入那一轮,那一轮的排名统统有统一的排名即可。

扫描二维码关注公众号,回复: 3005654 查看本文章

三,

注:队列只能取和更改队首的元素,不能取和更改队尾的元素。

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/82177696