程序设计基础16 tips 非二叉树求权重

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

一,关于结果的表示和存储问题:

    我的方法:用二维的vector存储每一条路径,但是二维vector输出略显麻烦,易出错。

    简便方法:用一维数组存储每一条路径,达到条件之后就在子函数DFS()中输出,但是关于有的路径长度不一样怎么办呢?解决方法就是在子函数DFS()中加入形参numNode,记录当前路径中的结点数目即可,即是这一个路径比上一个路径结点数目少,但是只遍历到numNode,就不管后面的了。

二,关于每一个结点的孩子结点如何由大到小排序的问题

    我的方法:

    这是不对的,主要在于sort里面的不能是与原数组(这里即为child这个vector)无关的东西,在这个vector里面比,sort就必须是这个vector.

int num = 0;
for (int j = 0; j < num; j++) {
    scanf("%d", &child);
    arr[num++] = child;
    node[root].child.push_back(child);
}
sort(arr,arr+num cmp);

bool cmp(int a, int b) {
	return node[a].weight > node[b].weight;
}

    正确方法:

    注意注释中的方法是错的,begin()和end()是vector比较指定专用方法。

for (int j = 0; j < num; j++) {
	scanf("%d", &child);
	node[root].child.push_back(child);
}
sort(node[root].child.begin(), node[root].child.end(), cmp);
//sort(node[root].child, node[root].child + num, cmp);


bool cmp(int a, int b) {
	return node[a].weight > node[b].weight;
}

三,正确代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
//到7:50 到8:25
const int maxn = 110;
int N = 0;
int M = 0;
int S = 0;
int path[maxn] = { 0 };
struct Node {
	int weight;
	vector<int> child;
}node[maxn];
bool cmp(int a, int b) {
	return node[a].weight > node[b].weight;
}
void DFS(int root, int numNode, int nowWeight) {
	if (node[root].child.size() == 0) {
		if (nowWeight == S) {
			for (int i = 0; i < numNode; i++) {
				printf("%d", node[path[i]].weight);
				if (i != numNode - 1) {
					printf(" ");
				}
			}
			printf("\n");
		}
		return;
	}
	if (nowWeight < S) {
		for (int i = 0; i < node[root].child.size();i++) {
			path[numNode] = node[root].child[i];
			DFS(node[root].child[i], numNode + 1, nowWeight + node[node[root].child[i]].weight);
		}
	}
}
int main() {
	int weight = 0;
	int root = 0;
	int num = 0;
	int child = 0;
	scanf("%d %d %d", &N, &M, &S);
	for (int i = 0; i < N; i++) {
		scanf("%d", &weight);
		node[i].weight = weight;
	}
	for (int i = 0; i < M; i++) {
		scanf("%d", &root);
		scanf("%d", &num);
		for (int j = 0; j < num; j++) {
			scanf("%d", &child);
			node[root].child.push_back(child);
		}
		sort(node[root].child.begin(), node[root].child.end(), cmp);//sort(node[root].child, node[root].child + num, cmp);
	}
	path[0] = 0;
	DFS(0, 1, node[0].weight);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/82665248