程序设计基础18 并查集(一)

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入

3
1 3
1 5
2 5
4
3 2
3 4
1 6
2 6

样例输出

4
5

一,思想方法:

本题目是一道典型的并查集问题。

1,注意的地方是在scanf()输入的第一轮Union后,想要对每个朋友圈的人数计数,不能采用

for (int i = 1; i <= max_id; i++) {
    ++group_num[father(i)];
}

而应当采用

for (int i = 1; i <= max_id; i++) {
	++group_num[findFather(i)];
}

原因是第一轮Union()后没有进行压缩彻底,例如1 3 和3 5,若是father[faA]=faB,数组会变成3 3 和3 5若是完全压缩应当是5 5 5 5

子函数如下:

int findFather(int x) {
	int a = x;
	while (x != father[x]) {
		x = father[x];
	}
	while (a != father[a]) {
		int z = a;
		a = father[a];
		father[z] = x;
	}
	return x;
}
void Union(int a, int b) {
	int faA = findFather(a);
	int faB = findFather(b);
	if (faA != faB) {
		father[faA] = faB;
	}
}

2,由于是多点测试,每次在输入之后都需要对father[]和group_num[]初始化,最好把初始化写在一个子函数里,看起来不冗余。

3,注意当输入的一个数据为0,即是0组朋友关系时,也要输出1,而不是0,就算没有一对朋友,也有一个人可以干活,因为题目规定了人数不是0.不要想当然。

二,我的代码

#include<cstdio>
#include<string.h>
using namespace std;
const int max_n = 10000010;
int father[max_n] = { 0 };
int group_num[max_n] = { 0 };
int findFather(int x) {
	int a = x;
	while (x != father[x]) {
		x = father[x];
	}
	while (a != father[a]) {
		int z = a;
		a = father[a];
		father[z] = x;
	}
	return x;
}
void Union(int a, int b) {
	int faA = findFather(a);
	int faB = findFather(b);
	if (faA != faB) {
		father[faA] = faB;
	}
}
void init() {
	for (int i = 1; i <= max_n; i++) {
		father[i] = i;
	}
	for (int i = 1; i <= max_n; i++) {
		group_num[i] = 0;
	}
}
int main() {
	int N = 0;
	int x = 0, y = 0;
	while (scanf("%d", &N) != EOF) {
		int max_id = -1;
		if (N == 0) {
			printf("1\n");
			continue;
		}
		init();
		for (int i = 0; i < N; i++) {
			scanf("%d %d", &x, &y);
			if (x > max_id) {
				max_id = x;
			}
			if (y > max_id) {
				max_id = y;
			}
			Union(x, y);
		}
		for (int i = 1; i <= max_id; i++) {
			++group_num[findFather(i)];
		}
		int num = 0;
		for (int i = 1; i <= max_id; i++) {
			if (group_num[i] > num) {
				num = group_num[i];
			}
		}
		printf("%d\n", num);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/82715837